Rotabili Italiani

Effettua l'accesso o una nuova registrazione.

Inserisci il nome utente, la password e la durata della sessione.
Ricerca avanzata  

News:

Autore Topic: E464  (Letto 39836 volte)

Worcester

  • Utente inesperto
  • **
  • Offline Offline
  • Post: 59
    • Mostra profilo
Re:E464
« Risposta #270 il: 02 Gennaio 2021 - 15:58:29 »

Ciao, per capire i problemi al minuto 2:30 e 3:02 dovrei riaprire lo script e debuggarlo sulla tratta nel video per vedere che succede effettivamente. Se per te non e' un problema creare uno scenario pari pari al video e passarmelo, vedo di darci un'occhio. Comunque, di che segnali stiamo parlando?
Connesso
Giorgio

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #271 il: 02 Gennaio 2021 - 16:22:24 »

Sono i segnali di Marco70, ovviamente, provo a prepararti il tutto quanto prima . . . grazie
Connesso
Andrea Irato

Worcester

  • Utente inesperto
  • **
  • Offline Offline
  • Post: 59
    • Mostra profilo
Re:E464
« Risposta #272 il: 02 Gennaio 2021 - 21:12:54 »

Ma grazie a te invece, il problema al minuto 2:30 e' in effetti un side effect derivante dal delay ricezione codice RSC che ho introdotto nella v4. E' un bug, quindi grazie a te per la segnalazione. Per il problema al minuto 3:02 invece, credo sia dovuto al flusso dei codici RSC inviati dai segnali che si accavallano e possono generare una cosa simile, cosa che ho constatato un po' di tempo fa, e che sarebbe da sistemare a livello dei segnali. Riverifichero' sullo scenario che mi invii comunque se la causa e' quella.
Connesso
Giorgio

Andrea66

  • Staff
  • Utente storico
  • ****
  • Offline Offline
  • Post: 1.835
  • Decresciamo felicemente
    • Mostra profilo
    • codadeltreno
Re:E464
« Risposta #273 il: 03 Gennaio 2021 - 10:34:31 »

x George,

come scritto su il topic dei miei oggetti, ho appena pubblicato un aggiornamento degli script dei segnali.
Mentre fai le verifiche per quanto segnalato da Ob73, e se hai la SFM installata, puoi magari verificare se molti dei problemi precedenti che avevi segnalato anche tu sono scomparsi.

Connesso
Andrea
codadeltreno.com

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #274 il: 03 Gennaio 2021 - 13:07:47 »

Connesso
Andrea Irato

Worcester

  • Utente inesperto
  • **
  • Offline Offline
  • Post: 59
    • Mostra profilo
Re:E464
« Risposta #275 il: 04 Gennaio 2021 - 23:39:21 »

@Andrea66: certo, vedro' di fare qualche test appena posso.
@Obelix73: ho provato ad aprire lo scenario in un breve ritaglio di tempo a disposizione, al posto del cod180* ricevo il 180. Inoltre le tabelle di vmax appaiono nel formato [ 0 xxx 0]. Sto dimenticando qualcosa?
Connesso
Giorgio

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #276 il: 05 Gennaio 2021 - 12:13:11 »

Non saprei, io ho usato le tabelle velocità di Cast ed i segnali di Marco70, il tutto posizionato rigorosamente come da FL e prescrizioni RFI . . .
Connesso
Andrea Irato

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #277 il: 05 Gennaio 2021 - 17:56:49 »

@ George, se ti può essere utile le macchine di Tiziano non danno alcun problema, ed il sorgente con la gestione RSC esiste ed è in chiaro (lo ha donato lui alla community a patto che non fosse per progetti a pagamento)
Connesso
Andrea Irato

Worcester

  • Utente inesperto
  • **
  • Offline Offline
  • Post: 59
    • Mostra profilo
Re:E464
« Risposta #278 il: 05 Gennaio 2021 - 19:10:48 »

Le problematiche non riguardano la gestione / captazione RSC che di per se e' la cosa piu' semplice. Le problematiche derivano dalla complessita' dello script che simula inoltre la RSC9 e SCMT, funzioni che gli script delle E646 ecc non hanno.
Connesso
Giorgio

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #279 il: 05 Gennaio 2021 - 19:29:22 »

Ok, quindi c'è qualcosa che non va tra segnali e loco, però i segnali ho usato quelli dichiarati compatibili . . . . provo a togliere i limiti . . . fossero quelli che infastidiscono, altrimenti non saprei proprio  :uhm
Connesso
Andrea Irato

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #280 il: 05 Gennaio 2021 - 22:44:12 »

Ok, segnali e limiti non c'entrano un tubo, la loco sì . . . ho provato la V3 della E464, spariti quasi tutti i problemi, comunque meglio della v4 . . . non so
Connesso
Andrea Irato

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #281 il: 08 Gennaio 2021 - 14:48:44 »

......
PSS: ricordo rimangono comunque da sistemare correttamente la posizione di tutte le tabelle di vmax, e la posizione di alcuni segnali per i quali il relativo codice RSC trasmesso non viene mantenuto per almeno 1350 o 900 m, il che genera alla ricezione del successivo codice la frenatura d'emergenza con RF possibile a 60 km/h (tabella A, allegato RSC tabella RFI TC.PATC ST CM 01 D23 C -- o manuale E464 5.4.3.3)
...
Questa tua risposta mi ha creato un dubbio, il segnale di avviso prima della protezione del 1° bivio Arezzo Nord, non ha queste caratteristiche (cioè non è alla distanza che specifichi, ma è la distanza riportata sul FL, reale al 100%). . .ho provato a toglierlo et-voilat,  la e464 V3 funziona egregiamente; adesso faccio delle prove anche con la V4
Connesso
Andrea Irato

Worcester

  • Utente inesperto
  • **
  • Offline Offline
  • Post: 59
    • Mostra profilo
Re:E464
« Risposta #282 il: 08 Gennaio 2021 - 20:49:22 »

Strano ci siano cambiamenti con la V3 poiche' quanto quotato (parte del SCMT) e' stato implementato nella v4. Nella v3 il SCMT non era stato ancora implementato. Comunque riguardo lo scenario di test, allego uno screen di come vedo lo scenario. Puo' essere che per errore sia una vecchia versione? I limiti mi appaiono cosi' come scritto nel messaggio precedente [0 xxx 0], poi sono in mph. Poi al sorpasso del limite, nel hud, il limite cambia da 140 a -14. Inoltre come dicevo non ho le stesse sequenze rsc, poiche' ho i limiti e vmax sballate causa diversa unita' di misura. Inoltre manca la inclinazione in curva, che mi pare di aver visto nel video. Di conseguenza, non riesco a testare il bug @2:30 del video.
Connesso
Giorgio

Obelix73

  • Utente storico
  • *****
  • Offline Offline
  • Post: 1.287
  • "Lunga vita e Prosperità"
    • Mostra profilo
Re:E464
« Risposta #283 il: 08 Gennaio 2021 - 23:00:11 »

Credo di aver trovato io il vulnus della questione . . . . termino gli ultimi test e ti faccio sapere
Connesso
Andrea Irato

Worcester

  • Utente inesperto
  • **
  • Offline Offline
  • Post: 59
    • Mostra profilo
Re:E464
« Risposta #284 il: 17 Gennaio 2021 - 18:10:48 »

Salve, ho avuto un po' di tempo per verificare le problematiche segnalate e ricontrollare lo script. Ecco un riassunto della situazione attuale.
  • Riguardo la questione SV, VM su tratte aventi velocita' < 180 km/h ho risposto http://www.rotabili-italiani.org/index.php?topic=253.msg29295#msg29295.
  • Riguardo il problema cambio istantaneo da C120* a C120 segnalato nel video di Andrea al minuto 2:30, e' confermato essere un bug della E464. @Obelix73: sono riuscito a sistemare la tratta e verificare questo problema. Riguardo la tratta, non era selezionata alcuna trackrule nella tratta, non so come mai. Risolto con RWtools, si sono sitemati unita' di misura e vmax tabelle.
  • Riguardo al problema cambio intermittente codice segnalato nel video al minuto 3:02, non sono riuscito a riprodurre il problema: ottengo C75 davanti al segnale giallo invece (come mai non so, sia E464 che E646). Ad ogni modo, come accennavo su, i codici vengono inviati dai segnali e la E464 (come la E646) mostra quanto riceve. Personalmente credo la causa sia l'accavallamento dei codici di segnali diversi (nel segnalamento di marco70), cosa a cui accennavo qualche messaggio fa', e ho riconfermato oggi. Per chi fosse interessato, posso allegare un log file che ho generato, che cattura i messaggi inviati dai segnali lungo il percorso fatto e mostra la non continuita dei codici ricevuti.
  • Per quanto riguarda la compatibilita' con i segnali della SFM di Andrea66, con il nuovo aggiornamento di questi ultimi, tali segnali sono quasi del tutto compatibili. Il "quasi" e' dovuto ad una gestione diversa dei segnali rossi (@Andrea66: nei tuoi segnali il rosso ha pro-state = -1 mentre nei segnali di marco70 il pro-state = 3). Se usata la E464 su tratte aventi i segnali della SFM, non funzioneranno relativamente ai soli segnali rossi le seguenti features:
    • curve CMT
    • curve RSC
    • abbassamento vril presso paraurti
    • SR
    Se si vuole ottenere una compatibilita' completa, sarebbe solo da impostare il pro-state su 3.
  • @Andrea66: Ho notato che il nuovo aggiornamento i codici non sono trasmessi continuamente. Tenere conto pero' che se da un lato vi e' un profondo aumento in prestazioni, tale modifica puo' impattare il funzionamento della RSC a bordo di una data loco. In particolare, essendo un dato codice trasmesso alla loco 1 volta sola, uno spegnimento della RSC a bordo ed una sua riaccensione provoca la perdita del codice captato in quanto gia' captato quindi mostra AC. Questo avviene (testato) sulle loco di Tiziano, ad esempio, in quanto suppongo siano stateless, cioe' non ricordano il messaggio captato. La E464 non e' affetta da questo problema perche' gia' ricordava il codice per fare i suoi ragionamenti.
  • Ricordo in generale l'importanza del rispetto della posa dei segnali garantendo la presenza di un dato codice RSC per tot metri e il posizionamento delle tabelle di vmax secondo la normativa RFI, di cui la E464 tiene conto.
Connesso
Giorgio
Pagine: 1 ... 17 18 [19] 20   Vai su