Rotabili Italiani

Effettua l'accesso o una nuova registrazione.

Inserisci il nome utente, la password e la durata della sessione.
Ricerca avanzata  

News:

Autore Topic: Problema con i loft  (Letto 864 volte)

exp 1648

  • Admin
  • Utente storico
  • *****
  • Offline Offline
  • Post: 757
  • RW Developer creator...
    • Mostra profilo
Problema con i loft
« il: 03 Giugno 2016 - 18:46:33 »

Stavolta sono io ad avere un problema e a chiedere un consiglio  :asd :shootme

Ieri sera ho provato a creare un loft e mi sono accorto che, nonstante imposti tutto correttamente in 3Ds Max, il loft appare invisibile.
Idem per un binario in 3D che ho provato a riesportare con nuove texture: Vedo solo le traversione ma il binario (il loft appunto), no...

Visto e considerato che un problema simile mi si è presentato con i carrelli delle vivalto, non è che con TS 2016 sono cambiate alcune cose?  :uhm
Chi altri ha avuto problemi con i loft?

Come materiale uso il "RW materials" e come shader il "LoftTextDiff.fx" (classio, fin dai tempi della kuju) applicando una texture in formato .DDS con MipMap e compressione x.8.8.8.8
Connesso
Fabio Bosi_____________Email: ffabio89[at]hotmail.it // Skype: fabio.bosi89
Lavori attualmente in corso per RW3 - TS 2014:
> Tratta reale "Ferrovie Emilia Romagna"- 12% secondo lotto
> Tratta di fantasia "Linea di confine"- 38%
> Carrozze Vivalto - 27%
> Aln 668 - 16%

Andrea66

  • Staff
  • Utente storico
  • ****
  • Offline Offline
  • Post: 1.807
  • Decresciamo felicemente
    • Mostra profilo
    • codadeltreno
Re:Problema con i loft
« Risposta #1 il: 03 Giugno 2016 - 19:05:51 »

No, nn è cambiato niente, però i loft ogni tanto fanno impazzire.

Possibili issue, dalle più banali, ma è sempre meglio verificare:
1) pivot non correttamente posizionato in 3d max, se corretto, controlla che il loft non sia sottoterra
2) Controlla che le facce siano correttamente "girate". Per esserne sicuro, selezione una faccia, applicargli un bevel e vedi che per valori positivi vada nella direzione corretta, cioè verso l'osservatore
3) Seleziona l'oggetto e applica un reset xform che trovi sotto le utilità di 3d max.

Cominciamo con questo, poi vediamo..
Connesso
Andrea
codadeltreno.com

fabiot

  • Admin
  • Utente storico
  • *****
  • Offline Offline
  • Post: 2.435
  • Router, creatore 3d
    • Mostra profilo
Re:Problema con i loft
« Risposta #2 il: 03 Giugno 2016 - 19:30:19 »

Ciao omonimo, pure io dal cambio 3ds max 10 a max 11 ho avuto lo stesso problema.


Come mi ha suggerito Andrea, ho usato ResetXform e tutto era visibile, ho usato questo strumento alla fine (quindi era giá texturizzato, faccie inutili eliminate ecc), fai cosi e vedi che avrai risolto.
Connesso
Fabio Torchia


Intel Dual Core E8500 3,16 GHz, Scheda Madre Asus P5QL-E, 4GB RAM DDR2, Nvidia GTX 640 2GB DDR3, Windows 10 Pro, 1TB HD

Intel i7 7740X LGA 2066, scheda madre MSI X299M A PRO, 16GB RAM DDR4, Scheda Video ZOTAC NVIDIA GTX 1080 8GB GDDR5, Windows 10 PRO, 500 GB SDD, 2TB HD